EVDOforums.com
Discussion forum for EVDO users
 
 FAQFAQ   SearchSearch   MemberlistMemberlist   UsergroupsUsergroups 

View previous topic :: View next topic  
Author Message
Michael
Site Admin


Joined: 13 Jan 2005
Posts: 6221
Location: Cary, IL

PostPosted: Sat Mar 31, 2007 1:52 pm    Post subject: Cisco 3G WWAN HWIC for EVDO



Quote:

CISCO 3G WAN Interface Card for Verizon or Sprint

Product Overview

The Cisco 3G WWAN HWICs are the first enterprise-class 3G WWAN solution. Suitable for both backup and primary applications, the Cisco 3G WWAN HWICs support the latest CDMA and GSM/UMTS standards (EVDO Rev A and HSDPA) and are backward compatible with the widely deployed networks (1xRTT, GPRS/EDGE). The Cisco 3G WWAN HWICs are tightly integrated with the services provided on the award-winning Cisco Integrated Services Routers, which deliver secure data, voice, video, and mobility services. The Cisco 3G WWAN HWICs are supported on the modular Cisco 1841 Integrated Services Router and Cisco 2800 Series and 3800 Series Integrated Services Routers.
Enterprises are looking for ways to reduce costs, increase revenue, and improve business continuity. The Cisco 3G WWAN HWICs, when coupled with a service provider wireless data plan, provide a cost-effective, rapidly deployable, reliable, and secure backup solution for remote sites and branch offices. With data rates approaching T1 speeds, 3G Networks provide an alternative to wireline backup solutions such as ISDN, cable, and DSL. In the event of a network failure, the Cisco Integrated Services Router routes mission-critical data to the Cisco 3G WWAN HWIC for transmission across the wireless infrastructure. In addition, the router can distinguish different types of traffic and allow only mission-critical traffic to flow over the backup interface.
The 3G Wireless WAN HWICs are available in two different SKUs. The CDMA SKU is called HWIC-3G-CDMA-x

*
HWIC-3G-CDMA-V (Verizon)
*
HWIC-3G-CDMA-S (Sprint)

Primary Connectivity
For applications that have low data usage but high security requirements such as bank ATMs, gas station kiosks, and telemetry sites, the Cisco 3G WWAN HWIC offers a secure, simplified, and cost-effective WAN alternative to DSL or Frame Relay. In areas where terrestrial broadband services (cable, DSL, or T1) are not available or are expensive, 3G WWAN connectivity can be a viable alternative.
For businesses requiring rapid setup or temporary connectivity, 3G WWAN offers the capability to bring up a new site quickly and cost effectively. Using the integrated services available on the Cisco Integrated Services Routers, Cisco 3G WWAN HWICs can provide instant and mobile communications during disasters and service outages.

Key Features and Benefits

* Integrated 3G WWAN broadband-With the 3G WWAN modem integrated into the router, customers gain the benefit of simplified installation and management. In addition, the Cisco 3G WWAN HWICs are tightly integrated with Cisco Integrated Services Routers, which run the industry-leading Cisco IOSĀ® Software, giving customers access to all the advanced features of Cisco IOS Software such as quality-of-service (QoS), intelligent network queuing, and robust security.
*
* Short installation time-Businesses sometimes wait for weeks or months to get data circuits installed at new locations. For temporary or seasonal sites, wireless data services allow instant connectivity anywhere there is cellular coverage, and rapid deployment allows customers to quickly set up networks with WAN connectivity
*
* Network resiliency through WAN diversity-WAN connectivity is crucial to the functioning of businesses, and any downtime means a loss of productivity and lost of opportunity. Staying connected and operational during a network outage can be vital. A wireless connection for backup to a remote site provides protection against line outages and an additional level of redundancy as the 3G WWAN infrastructure is often served by separate facilities, providing redundancy for the entire local loop.
*
* Reduced cost-The emerging 3G WWAN cellular data service plans are competitively priced with existing wire line services (ISDN, DSL, and cable). 3G WWAN solutions also allow customers to consolidate their service providers across large geographical areas instead of having service contracts with multiple service providers.
*
* Portability-Wireless routers and Cisco 3G WWAN HWICs can be easily relocated wherever coverage is available.
*
* Performance-With data usage on the rise and the proliferation of Web-based applications at remote sites, there is an increasing need for high-speed (broadband) data connections to run mission-critical applications at these sites. 3G WWAN services promise low-latency links at speeds app

The 3G wireless high-speed WAN interface cards (HWICs) offer a compelling alternative to traditional wireline backup solutions for the Cisco 1800 Series, 2800 Series, and 3800 Series integrated services routers. The 3G wireless HWIC provides WAN backup using terrestrial cellular technology. This results in a true multipath WAN backup solution that delivers higher performance over ISDN solutions at a fraction of the cost.

Ideal for primary broadband connections, the 3G HWIC delivers WAN connectivity in a fraction of the time required to install a traditional wired WAN connection. Configurations include:

* HWIC-3G-CDMA supporting 1xEV-DO Rev A, 1x EV-DO Rev 0, and 1xRTT
* HWIC-3G global system for mobile communications (GSM) supporting high-speed downlink packet access (HSDPA), universal mobile telecommunications service (UMTS), edge networks, and general packet radio service (GPRS)

The 3G wireless HWIC automatically selects the best available service based on wireless network availability in the service area.

Uses:

* WAN backup: Deployed as a secondary WAN connection
* Primary WAN link: Benefits areas where traditional wired solutions are unavailable, infeasible, or costly
* Mobile Business: Supports businesses that require frequent set-up, tear down, and relocation
* Flexible, Anyplace Connectivity: Ideal for low data volumes and high-security applications, such as bank ATMs, gas station kiosks, and telemetry sites


The Verizon & Sprint version includes an embedded Sierra Wireless Module and will have an estimated retail price of $850 (may be more after adding additional accessories). We will know more after Cisco ships the device. Also, we may be reselling this device along with activation. More on this as the product becomes available. The HWIC-3G-CDMA-V is for Verizon and the HWIC-3G-CDMA-S is for Sprint.


Other Related Links:

CISCO 3G WAN Interface Card for Verizon or Sprint

CISCO 3G WAN Interface Card
_________________
3Gstore.com
Back to top
View user's profile Send e-mail Visit poster's website
Camarones
EVDO User


Joined: 23 Oct 2006
Posts: 27
Location: Southern California

PostPosted: Tue Apr 03, 2007 2:14 pm    Post subject:

I posted about these devices a month ago and nobody seemed to care then either! Smile

http://www.evdoforums.com/thread5137.html

Did they announce when they'll be available?
Back to top
View user's profile
larkspur
EVDO Newbie


Joined: 20 Jul 2007
Posts: 6

PostPosted: Fri Jul 20, 2007 11:08 am    Post subject:

I have the 3G WHWIC in my cisco 1841 with teh 12.4 IOS.

The issue I face is the cell int does not stay up very long and it takes a long time to uptain an ip address.

config from Cisco 1841 ISR
chat-script cdma "" "ATDT#777" TIMEOUT 60 "CONNECT"

interface Cellular0/1/0
ip address negotiated
encapsulation ppp
dialer in-band
dialer string cdma
dialer-group 1
async mode interactive
ppp chap hostname (left blank on purpose)@vzw3g.com
ppp chap password 0 (left blank on purpose)

ip route quad zero's cell 0/1/0

line 0/1/0
exec-timeout 0 0
script dialer cdma
login
modem InOut
no exec
rxspeed 2400000
txspeed 153000

any idea's are greatly appreciated.
Back to top
View user's profile
ekoons
EVDO Newbie


Joined: 20 Jul 2007
Posts: 5

PostPosted: Fri Jul 20, 2007 2:39 pm    Post subject:

I have an 3G HWIC in a 1841, I've got it configured as a backup link, and it seems to disconnect quite frequently as well. I've got a case open with Cisco. If anyone finds out anything please share the info.
Back to top
View user's profile
larkspur
EVDO Newbie


Joined: 20 Jul 2007
Posts: 6

PostPosted: Sat Jul 21, 2007 9:07 am    Post subject:

Hey I was able to get the link to stay up while I was testing. I ran citrix session and a few other sites, youtube, espn.com to just check on latency.
Also noticed the 23 hops to get to my citrix frontends, which obviously adds latency.

I also contacted my vzw rep to report the frequent up down state, apparenlty they need to provsion the esn for RSSI ( this is what it is set to currently) or EVDO, in addtion a static ip address would be useful for ipsec sessions.

to get the link to stay up I changed a few settings to teh cell interface.

If you are interested I can post or e-mail my config as i has changed since the earlier post.
Back to top
View user's profile
ekoons
EVDO Newbie


Joined: 20 Jul 2007
Posts: 5

PostPosted: Sat Jul 21, 2007 11:23 am    Post subject:

Yeah, if you could post the config here or Private message me your email. I don't have enough posts to PM. Also, are you using this connection as a primary or backup link?
Back to top
View user's profile
larkspur
EVDO Newbie


Joined: 20 Jul 2007
Posts: 6

PostPosted: Mon Jul 23, 2007 7:25 am    Post subject:

The project is to test as a back up or primary connectivity for some of my remote sites.

I think this is a very useful soltuion for out of band management, although it maybe bit a more exspenvie then hanging a modem off a router.

version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname cell_router
!
boot-start-marker
boot-end-marker
!
logging buffered 4096
!
no aaa new-model
ip cef
!
!
!
!
ip name-server (used my external DNS)
multilink bundle-name authenticated
chat-script cdma "" "ATDT#777" TIMEOUT 60 "CONNECT"
!
!
interface FastEthernet0/0
ip address 192.168.254.12 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet0/1
no ip address
shutdown
duplex auto
speed auto
!
interface Serial0/0/0
no ip address
shutdown
no fair-queue
!
interface Cellular0/1/0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string cdma
dialer-group 1
async mode interactive
ppp chap hostname ( verizon wireless account)
ppp chap password ( password)
ppp ipcp dns accept
routing dynamic
!
ip route 0.0.0.0 0.0.0.0 Cellular0/1/0
!
!
ip http server
no ip http secure-server
ip nat inside source list 1 interface Cellular0/1/0 overload
!
access-list 1 permit any
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
line 0/1/0
exec-timeout 0 0
script dialer cdma
login
modem InOut
no exec
transport input all
transport output all
rxspeed 2400000
txspeed 153000

TOday my rep should be changing the proviosning on this esn to give me 3meg\1meg and a static ip address. I have not test crypto maps but I am confident they will not introduce much latency (split tunnel vpn).

let me know if I can help with anything.
Back to top
View user's profile
ekoons
EVDO Newbie


Joined: 20 Jul 2007
Posts: 5

PostPosted: Mon Jul 23, 2007 1:42 pm    Post subject:

Hmm, yours is pretty much the same as mine, as far as the cellular interface config. My cell interface will stay up indefinitely if I shutdown the f0/0 interface and make the cell interface the primary internet feed. But once I set it as backup to the f0/0 interface it seems to flap constantly. Here is my config, this is pretty much a copy of what cisco has in their online documentation. I'm still waiting for cisco to call back!!
The weird thing is, even though I physically remove the cable to f0/0 about a minute after the cell interface comes up, it says f0/0 has changed state to up, which then brings down the cell interface.

Current configuration : 3591 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TV2ProductionTruck
!
boot-start-marker
boot system flash flash:c1841-adventerprisek9-mz.124-15.T.bin
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool DHCPPool
import all
network 192.168.50.0 255.255.255.0
default-router 192.168.50.1
!
!
ip name-server 204.186.0.201
!
multilink bundle-name authenticated
chat-script cdma "" "ATDT#777" TIMEOUT 60 "CONNECT"
!
!
!
!
crypto isakmp policy 10
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key ******* address *.*.*.*
!
!
crypto ipsec transform-set pix-set esp-3des esp-md5-hmac
!
crypto map IPSEC 10 ipsec-isakmp
set peer *.*.*.*
set transform-set pix-set
match address 101
!
!
!
archive
log config
hidekeys
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface FastEthernet0/0
backup interface Cellular0/0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map IPSEC
!
interface FastEthernet0/1
description LAN Interface
ip address 192.168.50.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Cellular0/0/0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string cdma
dialer-group 1
async mode interactive
no ppp lcp fast-start
ppp chap password 0 cisco
ppp ipcp dns request
crypto map IPSEC
routing dynamic
!
ip local policy route-map track-primary-if
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 2
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0 254
!
!
no ip http server
no ip http secure-server
ip nat inside source route-map nat2cell interface Cellular0/0/0 overload
ip nat inside source route-map nonat interface FastEthernet0/0 overload
!
ip sla 1
icmp-echo 24.229.51.1 source-interface FastEthernet0/0
timeout 1000
frequency 2
ip sla schedule 1 life forever start-time now
logging trap debugging
access-list 1 permit any
access-list 10 permit 0.0.0.0 255.255.255.0
access-list 10 permit 192.168.50.0 0.0.0.255
aaccess-list 12 permit 192.168.50.0 0.0.0.255
access-list 12 permit 192.168.51.0 0.0.0.255
access-list 100 deny ip 192.168.50.0 0.0.0.255 192.168.51.0 0.0.0.255
access-list 100 permit ip 192.168.50.0 0.0.0.255 any
access-list 101 permit ip 192.168.50.0 0.0.0.255 192.168.51.0 0.0.0.255
access-list 102 permit icmp any host 24.229.51.1
dialer-list 1 protocol ip list 1
!
!
!
route-map track-primary-if permit 10
match ip address 102
set interface FastEthernet0/0
!
route-map nat2cell permit 10
match ip address 100
match interface Cellular0/0/0
!
route-map nonat permit 10
match ip address 100
match interface FastEthernet0/0
!
!
!
!
control-plane
!
!
!
line con 0
password ******
logging synchronous
login
line aux 0
line 0/0/0
exec-timeout 0 0
script dialer cdma
login
modem InOut
no exec
transport input all
transport output all
rxspeed 2400000
txspeed 153000
line vty 0 4
access-class 12 in
password *****
logging synchronous
login
line vty 5 15
access-class 12 in
password *****
logging synchronous
login
!
scheduler allocate 20000 1000

!
webvpn cef
end
Back to top
View user's profile
larkspur
EVDO Newbie


Joined: 20 Jul 2007
Posts: 6

PostPosted: Mon Jul 23, 2007 2:50 pm    Post subject:

A little unsure on the fast 0/0 config.

Why brings you to this type of setup?


interface FastEthernet0/0
backup interface Cellular0/0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map IPSEC
Back to top
View user's profile
ekoons
EVDO Newbie


Joined: 20 Jul 2007
Posts: 5

PostPosted: Mon Jul 23, 2007 2:50 pm    Post subject:

Hmm, yours is pretty much the same as mine, as far as the cellular interface config. My cell interface will stay up indefinitely if I shutdown the f0/0 interface and make the cell interface the primary internet feed. But once I set it as backup to the f0/0 interface it seems to flap constantly. Here is my config, this is pretty much a copy of what cisco has in their online documentation. I'm still waiting for cisco to call back!!
The weird thing is, even though I physically remove the cable to f0/0 about a minute after the cell interface comes up, it says f0/0 has changed state to up, which then brings down the cell interface.

Current configuration : 3591 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname TV2ProductionTruck
!
boot-start-marker
boot system flash flash:c1841-adventerprisek9-mz.124-15.T.bin
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
no ip dhcp use vrf connected
!
ip dhcp pool DHCPPool
import all
network 192.168.50.0 255.255.255.0
default-router 192.168.50.1
!
!
ip name-server 204.186.0.201
!
multilink bundle-name authenticated
chat-script cdma "" "ATDT#777" TIMEOUT 60 "CONNECT"
!
!
!
!
crypto isakmp policy 10
encr 3des
hash md5
authentication pre-share
group 2
crypto isakmp key ******* address *.*.*.*
!
!
crypto ipsec transform-set pix-set esp-3des esp-md5-hmac
!
crypto map IPSEC 10 ipsec-isakmp
set peer *.*.*.*
set transform-set pix-set
match address 101
!
!
!
archive
log config
hidekeys
!
!
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface FastEthernet0/0
backup interface Cellular0/0/0
ip address dhcp
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
crypto map IPSEC
!
interface FastEthernet0/1
description LAN Interface
ip address 192.168.50.1 255.255.255.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface Cellular0/0/0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer in-band
dialer idle-timeout 0
dialer string cdma
dialer-group 1
async mode interactive
no ppp lcp fast-start
ppp chap password 0 cisco
ppp ipcp dns request
crypto map IPSEC
routing dynamic
!
ip local policy route-map track-primary-if
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0 2
ip route 0.0.0.0 0.0.0.0 Cellular0/0/0 254
!
!
no ip http server
no ip http secure-server
ip nat inside source route-map nat2cell interface Cellular0/0/0 overload
ip nat inside source route-map nonat interface FastEthernet0/0 overload
!
ip sla 1
icmp-echo 24.229.51.1 source-interface FastEthernet0/0
timeout 1000
frequency 2
ip sla schedule 1 life forever start-time now
logging trap debugging
access-list 1 permit any
access-list 10 permit 0.0.0.0 255.255.255.0
access-list 10 permit 192.168.50.0 0.0.0.255
aaccess-list 12 permit 192.168.50.0 0.0.0.255
access-list 12 permit 192.168.51.0 0.0.0.255
access-list 100 deny ip 192.168.50.0 0.0.0.255 192.168.51.0 0.0.0.255
access-list 100 permit ip 192.168.50.0 0.0.0.255 any
access-list 101 permit ip 192.168.50.0 0.0.0.255 192.168.51.0 0.0.0.255
access-list 102 permit icmp any host 24.229.51.1
dialer-list 1 protocol ip list 1
!
!
!
route-map track-primary-if permit 10
match ip address 102
set interface FastEthernet0/0
!
route-map nat2cell permit 10
match ip address 100
match interface Cellular0/0/0
!
route-map nonat permit 10
match ip address 100
match interface FastEthernet0/0
!
!
!
!
control-plane
!
!
!
line con 0
password ******
logging synchronous
login
line aux 0
line 0/0/0
exec-timeout 0 0
script dialer cdma
login
modem InOut
no exec
transport input all
transport output all
rxspeed 2400000
txspeed 153000
line vty 0 4
access-class 12 in
password *****
logging synchronous
login
line vty 5 15
access-class 12 in
password *****
logging synchronous
login
!
scheduler allocate 20000 1000

!
webvpn cef
end
Back to top
View user's profile
ekoons
EVDO Newbie


Joined: 20 Jul 2007
Posts: 5

PostPosted: Mon Jul 23, 2007 3:25 pm    Post subject:

Sorry, somehow my previous post was posted twice. Don't know how that happened. Anyway. I think I see the problem. I found the config for a backup interface on cisco's website and it's specific for the HWIC-3G Card:
http://cisco.com/en/US/products/ps6441/products_feature_guide09186a00807ec85b.html#wp1158877

But, I think it's designed to be used as a backup with another type of serial/dialer connection, not as a backup to ethernet. I'm assuming what happens here is that when a Serial/ATM/DSL connection goes down the interface stays up, but the line protocol goes down initiating the cellular backup to dial. Well..pulling the ethernet cable on the ethernet interface causes both line protocol and interface to go down and I don't think the "backup interface" command quite knows how to handle that. The reason for the cellular as a backup to the ethernet is because this is getting installed in a TV Production truck. There are 2 locations where they do broadcasts where we have cable modem(Ethernet) connectivity so..the cellular is a backup, but there are many other places that we have no cable modem connectivity, thus the backup cellular connection comes in handy. Unfortunately, I can't be there for every broadcast, so reconfiguring the router based on location is not an option, it needs to be automatic.

Well, back to hunting the internet for a solution. Thanks for your help.
Back to top
View user's profile
larkspur
EVDO Newbie


Joined: 20 Jul 2007
Posts: 6

PostPosted: Mon Jul 23, 2007 3:40 pm    Post subject:

Do you have time to test teh connection first?

I started with just running icmp from the router out, then introduced nat and a node. Thsi allowed me to run a few debug commands to get thinsg settled.

Any chance you been down that road already?

e-mail me at janke2806@yahoo.com, i tried to PM, but they have us locked down dang it!!!!
Back to top
View user's profile
larkspur
EVDO Newbie


Joined: 20 Jul 2007
Posts: 6

PostPosted: Tue Aug 07, 2007 9:08 am    Post subject:

I had opened a TAC Case with Cisco who recommended upgrading to
12.4(15)T1 the connection speed picked up quite a bit and the cell interface stablized.

very happy, also this was with a Verizon 3G WHIC.

FYi - VW will also be implementing QoS in or around November of this year
Back to top
View user's profile
Display posts from previous:   
Page 1 of 1
Jump to:  
You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum